Tejas Motorsports

Author Topic: WARNING TO COBRA POWER PRO OWNERS!!!  (Read 24209 times)

marcelm

  • Road Star
  • **
  • *
  • *
  • Join Date: Oct 2011
  • Posts: 374
  • Location: Arad - Romania
  • Referrals: 0
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #165 on: Oct 30, 2012, 02:26:40 AM »
i wouldn't worry to much about knowing what the problem was as long as it is working properly.  :thumbs:

You are right, I only hope it will not happen again.
My life it's an endless fight against maturity.
"You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist."


AlanW.

  • Road Star
  • **
  • Join Date: Jun 2012
  • Posts: 383
  • Location: Conroe, Tx
  • Referrals: 0
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #166 on: Oct 30, 2012, 08:59:49 AM »
of course if you replace a bad o2 sensor than i am pretty sure that would fix the idle problem. Getting proper fuel air mix now.

michael t

  • Warrior
  • ****
  • Join Date: Mar 2012
  • Posts: 1754
  • Location: Outback Ky
  • Referrals: 0
    • View Profile
    • bersachat.com
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #167 on: Nov 10, 2012, 10:31:46 PM »
Quote
I have cleaned the stock air filter (easy hitting by a flat surface) and a lot of dust and mosquitos was coming out.



I vote Air Cleaner.  I fixed my TV for a long time with a wack on the side and sure other have also  ;D
[


Been there, Done it . Have License. Plate to prove it

” The Blood of AMERICAN HEROES is on Obama’s Hands…Remember Benghazi !! “

CobraUSA

  • Vendor
  • V Star
  • *
  • Join Date: May 2013
  • Posts: 4
  • Referrals: 0
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #168 on: Oct 09, 2013, 11:24:19 AM »
Hi,

I just heard about the gen 2 of Cobra PowrPro and know nothing about it.

What's the new think with the generation 2 of Cobra PowrPro ?
I both my Cobra PowrPro in april 2012 and don't know if it's the gen 2 or not. How can I find out this ?

Thanks
Marcel

if it is a gen 2 then one of the wires will have a piece of blue tape on it. Also the major difference between gen 1 and gen 2 is that if you pop open the gen 2 you will have a blue idle adjustment pod on the lower right side of the circuit board. The Gen 1 will not have this at all.

Thanks,

Mine has an orange tape on one of the wires, means is Gen. 1

Functional, the difference is that the Gen 2 is 100% controlling also the idle and IAC ?

Marcel, it only adjusts the idle, it has no affect on the IAC.

OK, thanks,

I'm trying to understand what was the problem with my bike, as there is no Yamaha dealer around my town   :(

I have stock air filter and LAChoppers exhausts.
Two month ago, I have installed Cobra PowrPro and the idle became not constant. I have removed the Cobra unit and idle come back to normal.

(I have phoned Cobra and they told me that reason should be air leakage somewhere. I told them that w/o the Cobra unit, the idle is OK, but they told that the stock ECU cannot detect that air leakage, if is not so big leakage. Cobra unit is not so "generous" as the ECU; then they told me to send the unit to them to check it.)

Anyway, after discussion with Cobra, I have notice that my O2 sensor is out of the order, is not working !  Imediately, I have bought new sensor from US.
Then I did the following operations : I installed the new O2 sensor and also I have cleaned the stock air filter (easy hitting by a flat surface) and a lot of dust and mosquitos was coming out.
Then, with Cobra PowrPro installed I have start the bike and the idle is normal, constant  :yay:

After all this, as lesson learned, I don't know what was the problem : the broken O2 sensor, or because I have cleaned up the air filter and the air is coming now, easily than before, which means there is no air leakage anymore, or is very small leakage. ... :shrug:

There is no difference between the original PowrPro and the ones with blue tape on them, other than the extra adjustment that the blue tape model has over the 02 sensors.  If your bike runs well as is, then your unit is working properly! 

What we know for sure is that if your bike has bad 02 sensors, it will not run properly with our PowrPro unit, since it works off of the 02 sensors.  We always recommend to take a look at your sensors to make sure they are still in good working condition.  What the blue unit does is allow you to pretty much turn off the sensors, which we don't recommend doing since that is something that really helps the PowrPro read everything that is going on with your bike.

If anyone has a question, please feel free to call customer service at (714) 692-8180.

Thanks!

gRimmM7_62

  • One of a kind! Oh, uhmmmmm, the bike not me!
  • 2014 ROM Winner
  • Roadliner
  • *
  • Join Date: Jul 2013
  • Posts: 526
  • Location: Bonham, TX
  • Referrals: 0
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #169 on: Oct 09, 2013, 11:46:21 AM »
Just a quick question to Cobra or anyone who knows.... can the PowerPro work with a wideband o2 sensor? Would it help or hurt performance from the unit in any way?
A bad tactic properly executed is better then a good tactic poorly executed!

Sweet Tooth

  • Raider
  • *****
  • Join Date: Nov 2011
  • Posts: 2508
  • Location: Mississippi
  • Referrals: 0
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #170 on: Oct 09, 2013, 01:21:07 PM »
Gotta say i have no regrets on the power pro. Its the first one .It pops ever now and then but i can deal with that .
Some prefer medicine. I prefer my Raider.

MYRDR

  • MSgt USMC Retired - Patriot Guard Rider
  • AZ Group
  • Raider
  • *****
  • *
  • *
  • Join Date: Sep 2011
  • Posts: 24248
  • Location: Yuma, AZ
  • Referrals: 3
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #171 on: Oct 11, 2013, 04:00:09 AM »
Just a quick question to Cobra or anyone who knows.... can the PowerPro work with a wideband o2 sensor? Would it help or hurt performance from the unit in any way?

I don't think it's going to matter if you use the stock or a wide band 02 sensor as long as you use one.  As Cobra stated the unit works off of the 02 sensor to help it get all the readings of what is going on with your bike.  I would recommend giving them a call just to make sure... Cobra customer service  (714) 692-8180.

marcelm

  • Road Star
  • **
  • *
  • *
  • Join Date: Oct 2011
  • Posts: 374
  • Location: Arad - Romania
  • Referrals: 0
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #172 on: Oct 11, 2013, 04:17:24 AM »
Hi,

I just heard about the gen 2 of Cobra PowrPro and know nothing about it.

What's the new think with the generation 2 of Cobra PowrPro ?
I both my Cobra PowrPro in april 2012 and don't know if it's the gen 2 or not. How can I find out this ?

Thanks
Marcel

if it is a gen 2 then one of the wires will have a piece of blue tape on it. Also the major difference between gen 1 and gen 2 is that if you pop open the gen 2 you will have a blue idle adjustment pod on the lower right side of the circuit board. The Gen 1 will not have this at all.

Thanks,

Mine has an orange tape on one of the wires, means is Gen. 1

Functional, the difference is that the Gen 2 is 100% controlling also the idle and IAC ?

Marcel, it only adjusts the idle, it has no affect on the IAC.

OK, thanks,

I'm trying to understand what was the problem with my bike, as there is no Yamaha dealer around my town   :(

I have stock air filter and LAChoppers exhausts.
Two month ago, I have installed Cobra PowrPro and the idle became not constant. I have removed the Cobra unit and idle come back to normal.

(I have phoned Cobra and they told me that reason should be air leakage somewhere. I told them that w/o the Cobra unit, the idle is OK, but they told that the stock ECU cannot detect that air leakage, if is not so big leakage. Cobra unit is not so "generous" as the ECU; then they told me to send the unit to them to check it.)

Anyway, after discussion with Cobra, I have notice that my O2 sensor is out of the order, is not working !  Imediately, I have bought new sensor from US.
Then I did the following operations : I installed the new O2 sensor and also I have cleaned the stock air filter (easy hitting by a flat surface) and a lot of dust and mosquitos was coming out.
Then, with Cobra PowrPro installed I have start the bike and the idle is normal, constant  :yay:

After all this, as lesson learned, I don't know what was the problem : the broken O2 sensor, or because I have cleaned up the air filter and the air is coming now, easily than before, which means there is no air leakage anymore, or is very small leakage. ... :shrug:

There is no difference between the original PowrPro and the ones with blue tape on them, other than the extra adjustment that the blue tape model has over the 02 sensors.  If your bike runs well as is, then your unit is working properly! 

What we know for sure is that if your bike has bad 02 sensors, it will not run properly with our PowrPro unit, since it works off of the 02 sensors.  We always recommend to take a look at your sensors to make sure they are still in good working condition.  What the blue unit does is allow you to pretty much turn off the sensors, which we don't recommend doing since that is something that really helps the PowrPro read everything that is going on with your bike.

If anyone has a question, please feel free to call customer service at (714) 692-8180.

Thanks!

Thank you,

Good to know that my problem was the bad O2 sensor.

As feedback, I'm very happy with my PowrPro. I do not have a dyno chart, but I know the PowrPro is doing  a great job with my bike, because I feel the EXTRA power given by the Pro, also very quick response from throttle.
I have only few poppings, but to be onest, I like them and how people turns heads ! it gives the impresion that something HUGE is around there ...  :)




My life it's an endless fight against maturity.
"You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist."

CobraUSA

  • Vendor
  • V Star
  • *
  • Join Date: May 2013
  • Posts: 4
  • Referrals: 0
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #173 on: Oct 24, 2013, 11:07:55 AM »
Hi,

I just heard about the gen 2 of Cobra PowrPro and know nothing about it.

What's the new think with the generation 2 of Cobra PowrPro ?
I both my Cobra PowrPro in april 2012 and don't know if it's the gen 2 or not. How can I find out this ?

Thanks
Marcel

if it is a gen 2 then one of the wires will have a piece of blue tape on it. Also the major difference between gen 1 and gen 2 is that if you pop open the gen 2 you will have a blue idle adjustment pod on the lower right side of the circuit board. The Gen 1 will not have this at all.

Thanks,

Mine has an orange tape on one of the wires, means is Gen. 1

Functional, the difference is that the Gen 2 is 100% controlling also the idle and IAC ?

Marcel, it only adjusts the idle, it has no affect on the IAC.

OK, thanks,

I'm trying to understand what was the problem with my bike, as there is no Yamaha dealer around my town   :(

I have stock air filter and LAChoppers exhausts.
Two month ago, I have installed Cobra PowrPro and the idle became not constant. I have removed the Cobra unit and idle come back to normal.

(I have phoned Cobra and they told me that reason should be air leakage somewhere. I told them that w/o the Cobra unit, the idle is OK, but they told that the stock ECU cannot detect that air leakage, if is not so big leakage. Cobra unit is not so "generous" as the ECU; then they told me to send the unit to them to check it.)

Anyway, after discussion with Cobra, I have notice that my O2 sensor is out of the order, is not working !  Imediately, I have bought new sensor from US.
Then I did the following operations : I installed the new O2 sensor and also I have cleaned the stock air filter (easy hitting by a flat surface) and a lot of dust and mosquitos was coming out.
Then, with Cobra PowrPro installed I have start the bike and the idle is normal, constant  :yay:

After all this, as lesson learned, I don't know what was the problem : the broken O2 sensor, or because I have cleaned up the air filter and the air is coming now, easily than before, which means there is no air leakage anymore, or is very small leakage. ... :shrug:

There is no difference between the original PowrPro and the ones with blue tape on them, other than the extra adjustment that the blue tape model has over the 02 sensors.  If your bike runs well as is, then your unit is working properly! 

What we know for sure is that if your bike has bad 02 sensors, it will not run properly with our PowrPro unit, since it works off of the 02 sensors.  We always recommend to take a look at your sensors to make sure they are still in good working condition.  What the blue unit does is allow you to pretty much turn off the sensors, which we don't recommend doing since that is something that really helps the PowrPro read everything that is going on with your bike.

If anyone has a question, please feel free to call customer service at (714) 692-8180.

Thanks!

Thank you,

Good to know that my problem was the bad O2 sensor.

As feedback, I'm very happy with my PowrPro. I do not have a dyno chart, but I know the PowrPro is doing  a great job with my bike, because I feel the EXTRA power given by the Pro, also very quick response from throttle.
I have only few poppings, but to be onest, I like them and how people turns heads ! it gives the impresion that something HUGE is around there ...  :)

Glad to hear everything is working for well for you! Once again, if anyone has questions I can try and answer them here, or contact customer service at (714) 692-8180

Thanks!

xmanrigger

  • Road Star
  • **
  • Join Date: Jul 2014
  • Posts: 151
  • Location: BC, Canada
  • Referrals: 0
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #174 on: Oct 22, 2014, 06:16:36 PM »
I had mine fail, but not sure if it was due to water or moisture. There were no visible water stains on PCB, but there was a burn mark on PCB around the potentiometer. Contacted Cobra and was sent a replacement PCB at no charge. Great support. I now siliconed the unit air tight.
Look to the right of the blue pot

2012 Raider / V&H Big Radius 2-1 / Cobra Fi2000 DFP / Baron Stealth Big Air / Avon AV72 Cobra Rear Tire

Zxdave

  • Road Star
  • **
  • Join Date: Sep 2014
  • Posts: 102
  • Location: Fredvegas Va.
  • Referrals: 0
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #175 on: Oct 23, 2014, 06:47:17 AM »
Just a quick question to Cobra or anyone who knows.... can the PowerPro work with a wideband o2 sensor? Would it help or hurt performance from the unit in any way?

I don't think it's going to matter if you use the stock or a wide band 02 sensor as long as you use one.  As Cobra stated the unit works off of the 02 sensor to help it get all the readings of what is going on with your bike.  I would recommend giving them a call just to make sure... Cobra customer service  (714) 692-8180.

Don't think that the pro works off of a/f readings from the O2 sensor , far as I know from my understandings it works off the crank sensor only .
It measures the time taken for the crank to make a full revolution and if you are on the gas it add enough fuel to make the crank turn faster on the next revolution .
99% sure the O2 is not involved in its calculations at all bro , but I could be wrong , ask my ex and she knows I was wrong all the time lol !!
Lean till it grinds , then lean some more ..

MYRDR

  • MSgt USMC Retired - Patriot Guard Rider
  • AZ Group
  • Raider
  • *****
  • *
  • *
  • Join Date: Sep 2011
  • Posts: 24248
  • Location: Yuma, AZ
  • Referrals: 3
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #176 on: Oct 23, 2014, 06:53:23 AM »
Just a quick question to Cobra or anyone who knows.... can the PowerPro work with a wideband o2 sensor? Would it help or hurt performance from the unit in any way?

I don't think it's going to matter if you use the stock or a wide band 02 sensor as long as you use one.  As Cobra stated the unit works off of the 02 sensor to help it get all the readings of what is going on with your bike.  I would recommend giving them a call just to make sure... Cobra customer service  (714) 692-8180.

Don't think that the pro works off of a/f readings from the O2 sensor , far as I know from my understandings it works off the crank sensor only .
It measures the time taken for the crank to make a full revolution and if you are on the gas it add enough fuel to make the crank turn faster on the next revolution .
99% sure the O2 is not involved in its calculations at all bro , but I could be wrong , ask my ex and she knows I was wrong all the time lol !!

The pro does need the 02 sensor to function properly, as CobraUSA stated in an earlier post in this thread: "What we know for sure is that if your bike has bad 02 sensors, it will not run properly with our PowrPro unit, since it works off of the 02 sensors."

dukedomain

  • Roadliner
  • ***
  • Join Date: Oct 2013
  • Posts: 910
  • Location: Central NC
  • Referrals: 0
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #177 on: Oct 23, 2014, 09:09:30 AM »
Just a quick question to Cobra or anyone who knows.... can the PowerPro work with a wideband o2 sensor? Would it help or hurt performance from the unit in any way?

I don't think it's going to matter if you use the stock or a wide band 02 sensor as long as you use one.  As Cobra stated the unit works off of the 02 sensor to help it get all the readings of what is going on with your bike.  I would recommend giving them a call just to make sure... Cobra customer service  (714) 692-8180.

Don't think that the pro works off of a/f readings from the O2 sensor , far as I know from my understandings it works off the crank sensor only .
It measures the time taken for the crank to make a full revolution and if you are on the gas it add enough fuel to make the crank turn faster on the next revolution .
99% sure the O2 is not involved in its calculations at all bro , but I could be wrong , ask my ex and she knows I was wrong all the time lol !!

The pro does need the 02 sensor to function properly, as CobraUSA stated in an earlier post in this thread: "What we know for sure is that if your bike has bad 02 sensors, it will not run properly with our PowrPro unit, since it works off of the 02 sensors."

I found that statement from Cobra a little confusing.  It was my understanding that the PP did not read off the O2 sensor.  Ivan told me to unplug my O2 and I've been running it like that since June.  I do feel like it runs a little rough in certain rpm ranges and feels a little sluggish (relatively) at times.

I am going to plug the O2 back up and see what happens.

t84a

  • Real Men Pedal
  • Raider
  • *****
  • *
  • Join Date: Aug 2011
  • Posts: 3124
  • Location: Middletown, MD
  • Referrals: 3
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #178 on: Oct 23, 2014, 09:11:38 AM »
Narrow band o2 sensors are for idle and steady throttle only.  You do not need to hook them up.

On the other hand, if they are bad, they would send bad info to the PP so Cobra's statement holds true.
Ken
2010 Raider
2008 FZ1

Words of Wisdom: Enjoy your fun time, don't be concerned about others trying to do the same.

JOIN THE AMA
Helmet Fact
My local powder coater

JB™

  • Warrior
  • ****
  • Join Date: Nov 2013
  • Posts: 1067
  • Location: Southern WV / Northern FL
  • Referrals: 0
    • View Profile
Re: WARNING TO COBRA POWER PRO OWNERS!!!
« Reply #179 on: Oct 23, 2014, 10:37:57 AM »
IMO, you need to have the O2 hooked up with the Powerpro.
The Powerpro itself does not use it, but it is needed during the times when the Power pro is being bypassed.
( idle and steady throttle )