Yamaha Road Star Raider Motorcycle Forum

Raider Categories => Technical Discussion => Topic started by: Echo720 on Jan 16, 2011, 12:45:19 am

Title: Neutral switch issue
Post by: Echo720 on Jan 16, 2011, 12:45:19 am
Okay, so here's my problem, when the kickstand is down the neutral switch turns off the light in the dash. but when the kickstand is raised and the bike is put in gear the neutral light in the dash stays illuminated no matter what gear the bike is in. anyone know what might cause this problem. the neutral switch is working at the connector under the seat. any input is greatly appreciated.
Title: Re: Neutral switch issue
Post by: A.T. on Jan 16, 2011, 04:10:43 pm
Have you been doing any work on the bike? I'd back track if so.  Other than that, check switch adjustment. 
Title: Re: Neutral switch issue
Post by: RedStar Raider on Jan 16, 2011, 06:30:19 pm
You could check under the speedo, and make sure all the wires are connected securely.
Title: Re: Neutral switch issue
Post by: TRaider_John on Jan 16, 2011, 08:16:07 pm
That is weird.  Sometimes the logic circuits act weird like that if all of the inputs aren't present.  Have you had the seat off?  There is a connector for the neutral switch under the seat.  Is there a chance you damaged the sidestand switch? 

On the other hand, it sounds as if the position of the sidestand and the gearbox are being sensed because they both seem to  affect the light.  That means the switches and wiring are intact.  That leaves the logic in the ECU.

I don't know, that's just weird. 
Title: Re: Neutral switch issue
Post by: Echo720 on Jan 17, 2011, 01:14:37 am
yeah it's gotta be something extremely stupid. when I checked the neutral switch for continuity I did it at the connection under the seat. I am going to do some more tracing when the weather goes more my way. just thought that it was funny since the kickstand being down The neutral light works properly (Bike Off) but when it's up that darn light just stays on. if it's one or the other works I guess i could live without the kick stand switch. having that big N glowing in my face would get annoying after awhile.
Title: Re: Neutral switch issue
Post by: Red Ryder on Jan 17, 2011, 05:47:35 pm
Sounds like you may have a short or shorted diode in the relay module.  The neutral switch and the sidestand switch both go to the relay module and one output drives the neutral light.  Do you have a service manual?  Page 7-81 tells how to test the relay module.  I believe the relay module is to the rear of the battery, under the ECU.
Title: Re: Neutral switch issue
Post by: RavenRaider on Jan 17, 2011, 06:32:48 pm
Have you been doing any work on the bike? I'd back track if so.  Other than that, check switch adjustment. 

From the looks of his Avatar, it appears the bike is bone stock.  Sorry Almost, couldn't resist the "here's your sign".  I just had to do it ;D

Echo, where's the pics of that bike?!?!?!  That thing looks awesome...........
Title: Re: Neutral switch issue
Post by: A.T. on Jan 17, 2011, 07:25:36 pm
From the looks of his Avatar, it appears the bike is bone stock.  Sorry Almost, couldn't resist the "here's your sign".  I just had to do it ;D

Yeah yeah...I'll wear it proudly.  It is a nice looking ride though... 
Title: Re: Neutral switch issue
Post by: RavenRaider on Jan 17, 2011, 07:33:46 pm
I like it A-L-O-T........
Title: Re: Neutral switch issue
Post by: Echo720 on Jan 18, 2011, 01:19:26 am
Have you been doing any work on the bike? I'd back track if so.  Other than that, check switch adjustment. 

From the looks of his Avatar, it appears the bike is bone stock.  Sorry Almost, couldn't resist the "here's your sign".  I just had to do it ;D

Echo, where's the pics of that bike?!?!?!  That thing looks awesome...........

I just posted 2 pics that I have on this Computer (My camera isn't the greatest, but it does OK) also I think I have some more on my other Computer. I will post more soon. I Just added LED Bullet tail/brake/turn lights (although they're hard to see in the night pic since those LED strips under the struts are blinding.) to the fender struts since it's got that L&M rear fender all it had on it when I got it was a Tail/Brake light license plate frame ( I don't know about anyone else, but I like to be seen when I hit the brakes or change lanes)

also there are quite a few pictures on sfcrick's profile since this used to be his bike. although those pictures are before the L&M fenders.
Title: Re: Neutral switch issue
Post by: strike 3 on Apr 04, 2012, 06:06:24 pm
Hey guys... Just wanted to comment on this issue.  Had the exact same problem.  Neutral light stayed on no matter what.  Checked the sidestand switch...neutral light stayed on.  Unplugged the connector under the seat to the neutral switch and grounded out the switch... light stayed on as well.  It left the fuel pump relay (number 39 on diagram).  Replaced that and it now works, so for future reference if anyone has a issue with the neutral light staying on and the first two items checked out..replace the fuel pump relay its bad and prolly the culprit.  They are cheap at like 20 to 25 dollars to fix. Wouldnt have thought that the fuel pump relay was tied into the neutral switch but it is!!
Title: Re: Neutral switch issue
Post by: LostDog on Apr 04, 2012, 06:10:35 pm
Thanks for the heads up strike 3!
Title: Re: Neutral switch issue
Post by: Fj_Ohio on Apr 04, 2012, 07:24:03 pm
Hey Strike. Where did you purchase the replacement? Thanks.
Title: Re: Neutral switch issue
Post by: strike 3 on Apr 04, 2012, 07:57:22 pm
Hey Strike. Where did you purchase the replacement? Thanks.

No problem man.  The part number is    5VK-81950-30-00.  I usually shop at partspak or boats.net.  You can do a search and possibly get them cheaper.  Hope this helps bro!
Title: Re: Neutral switch issue
Post by: TRaider_John on Apr 05, 2012, 04:32:58 am
Wow!  This thread is a keeper.
Title: Re: Neutral switch issue
Post by: strike 3 on Apr 08, 2012, 08:43:52 am
Wow!  This thread is a keeper.

Yeah John...why I went back and dug it up.  Will save folks alot of headaches one day!
Title: Re: Neutral switch issue
Post by: Rick Busbea on Jul 02, 2012, 12:26:49 pm
Another thing to watch out for on this is that both switch wires come out of the left side of the handlebar and are exactly the same in appearance.  I know because I inadvertently switched them when I changed out the bars and have the same issue as described here.  Yep, I'm a dork at times - just didn't notice they were exactly the same until it came time to reconnect and was impossible at that time to tell which was which.  BTW, same issue on right handlebar with the same colored wires - that was handbrake switch and something else I can't remember now.  Be careful when doing handlebar swap.   O8O