Author Topic: Neutral Light....  (Read 193 times)

TeleMan

  • Road Star
  • **
  • Join Date: Jun 2014
  • Posts: 72
  • Referrals: 0
Neutral Light....
« on: May 20, 2020, 01:26:23 pm »
Hey all,

I was riding my Raider today in damp conditions (light rain, wet roads) and I noticed that my neutral indicator light was turning on slightly (dim light) when I pulled the clutch in to shift/downshift. Upon releasing the clutch fully, the light went out.

At a stoplight, putting the bike in neutral made the light illuminate fully, but obviously something got wet.  I wanted to see if anyone else had this issue, and where the switch is located so I can see how much water (and from where) is getting in.  Wet electronics are NOT a good thing last time I checked.

Thanks
2011 Yamaha Raider.  Memphis Shades 15" windshield

RoadStarRaider

  • Advertisement
  • ***

    sundancer87

    • Road Star
    • **
    • Join Date: May 2012
    • Posts: 288
    • Referrals: 0
    Re: Neutral Light....
    « Reply #1 on: May 20, 2020, 02:30:07 pm »

    the urban legend

    • Raider
    • *****
    • Join Date: Sep 2011
    • Posts: 3689
    • Referrals: 0
    Re: Neutral Light....
    « Reply #2 on: May 20, 2020, 05:37:26 pm »
    #3 shown on the left side of engine  https://www.partzilla.com/catalog/yamaha/motorcycle/2009/raider-s-xv19csyb/electrical-1

    Actually I believe it's on the right side.

    You might want to check out the relay unit. It controls all the logistics for the starter safety protocols, like clutch switch, neutral switch, and sidestand switch. It's located between the battery box and the rear fender, so the fender has to come off (easy job). It should be to the right, and has a 16 cavity connector with only 13 wires.
    I'd rather die on a motorcycle than live without one.

    ,,